MyTouchMath Digital Classroom - Connection Issues - dysctest.com – Incident details

All systems operational

Connection Issues - dysctest.com

Resolved
Major outage
Started about 2 months agoLasted about 2 hours

Affected

dysctest.com
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are investigating connection issues affecting DySc Assessment. Our team has identified the root cause and is actively working on restoring service. We will provide updates as more information becomes available.